5.1.1商业版安装 节点的时候节点安装不上


#1

Error: Package: php-bcmath-5.4.16-36.3.el7_2.x86_64 (transwarp)
Requires: php-common(x86-64) = 5.4.16-36.3.el7_2
Available: php-common-5.4.16-36.3.el7_2.x86_64 (transwarp)
php-common(x86-64) = 5.4.16-36.3.el7_2
Installing: php-common-5.4.16-42.el7.x86_64 (os)
php-common(x86-64) = 5.4.16-42.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Thu Jan 25 20:40:18 CST 2018 [SSH] exit status: 1
Thu Jan 25 20:40:18 CST 2018 [Manager] The command is necessary but failed!
Thu Jan 25 20:40:18 CST 2018 [Manager] Node installation failed!
Command exit with exit code 1; error message:


#2

在服务器上把php-common删掉。然后重装。就可以了。

具体操作可参考:

  1. yum list | grep php-common,查看系统可安装的php-common版本是否对应5.4.16-36.3.el7_2
  2. yum remove php-common -y
  3. yum install php-common -y
  4. 重新安装即可。

#3

问题已经解决,原因是使用了centos7.4版本 因为7.2的centos镜像不支持使用wifi模式连接而7.4支持,但是5.1.1版本安装7.4版本又会出现这个错误导致节点安装不上。 所以建议节点还是使用7.2版本的操作系统+7.2的镜像源,连接网络的话最好多准备几根网线连接路由器


在线客服
在线客服
微信客服
微信客服