php版本问题


#1

Complete!
Tue Dec 26 03:55:49 UTC 2017 [SSH] exit status: 0
Tue Dec 26 03:55:49 UTC 2017 [SSH] execute command: yum -y install ganglia-web
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
–> Running transaction check
—> Package ganglia-web.x86_64 0:3.7.1-2.el7 will be installed
–> Processing Dependency: php-gd for package: ganglia-web-3.7.1-2.el7.x86_64
–> Processing Dependency: php-ZendFramework for package: ganglia-web-3.7.1-2.el7.x86_64
–> Processing Dependency: php for package: ganglia-web-3.7.1-2.el7.x86_64
–> Running transaction check
—> Package php.x86_64 0:5.4.16-42.el7 will be installed
–> Processing Dependency: php-common(x86-64) = 5.4.16-42.el7 for package: php-5.4.16-42.el7.x86_64
–> Processing Dependency: php-cli(x86-64) = 5.4.16-42.el7 for package: php-5.4.16-42.el7.x86_64
—> Package php-ZendFramework.noarch 0:1.12.20-1.el7 will be installed
–> Processing Dependency: php-xml for package: php-ZendFramework-1.12.20-1.el7.noarch
–> Processing Dependency: php-process for package: php-ZendFramework-1.12.20-1.el7.noarch
–> Processing Dependency: php-bcmath for package: php-ZendFramework-1.12.20-1.el7.noarch
—> Package php-gd.x86_64 0:5.4.16-42.el7 will be installed
–> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: php-gd-5.4.16-42.el7.x86_64
–> Processing Dependency: libt1.so.5()(64bit) for package: php-gd-5.4.16-42.el7.x86_64
–> Processing Dependency: libjpeg.so.62()(64bit) for package: php-gd-5.4.16-42.el7.x86_64
–> Processing Dependency: libXpm.so.4()(64bit) for package: php-gd-5.4.16-42.el7.x86_64
–> Running transaction check
—> Package libXpm.x86_64 0:3.5.12-1.el7 will be installed
—> Package libjpeg-turbo.x86_64 0:1.2.90-5.el7 will be installed
—> Package php-bcmath.x86_64 0:5.4.16-36.3.el7_2 will be installed
–> Processing Dependency: php-common(x86-64) = 5.4.16-36.3.el7_2 for package: php-bcmath-5.4.16-36.3.el7_2.x86_64
—> Package php-cli.x86_64 0:5.4.16-42.el7 will be installed
—> Package php-common.x86_64 0:5.4.16-42.el7 will be installed
–> Processing Dependency: libzip.so.2()(64bit) for package: php-common-5.4.16-42.el7.x86_64
—> Package php-process.x86_64 0:5.4.16-42.el7 will be installed
—> Package php-xml.x86_64 0:5.4.16-42.el7 will be installed
—> Package t1lib.x86_64 0:5.1.2-14.el7 will be installed
–> Running transaction check
—> Package libzip.x86_64 0:0.10.1-8.el7 will be installed
—> Package php-bcmath.x86_64 0:5.4.16-36.3.el7_2 will be installed
–> Processing Dependency: php-common(x86-64) = 5.4.16-36.3.el7_2 for package: php-bcmath-5.4.16-36.3.el7_2.x86_64
–> Finished Dependency Resolution
Error: Package: php-bcmath-5.4.16-36.3.el7_2.x86_64 (transwarp)
Requires: php-common(x86-64) = 5.4.16-36.3.el7_2
Available: php-common-5.4.16-36.3.el7_2.x86_64 (transwarp)
php-common(x86-64) = 5.4.16-36.3.el7_2
Installing: php-common-5.4.16-42.el7.x86_64 (os)
php-common(x86-64) = 5.4.16-42.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Tue Dec 26 03:55:51 UTC 2017 [SSH] exit status: 1
Tue Dec 26 03:55:51 UTC 2017 [Manager] The command is necessary but failed!
Tue Dec 26 03:55:51 UTC 2017 [Manager] Node installation failed!
Command exit with exit code 1; error message:

安装节点的时候一直报这个,卸载php重装都不行,有没有知道的大佬怎么解决这个问题。


#2

卸载php-common,然后重装


#3

你的操作系统跟transwarp是什么版本?? 我之前安装的时候也遇到过这种问题,根据transwarp版本替换相应的操作系统版本就好了


#4

请问你那边是不是RHEL 7.3或者7.4的操作系统, 参考下http://support.transwarp.cn/t/centos-7-3-7-4-ganglia-web-php-bcmath/1722 试下能够解决问题。


#5

你的系统版本是多少的?是系统的不兼容问题把?


在线客服
在线客服
微信客服
微信客服